Threat Level: green Handler on Duty: Russ McRee

SANS ISC: Microsoft Patches appear to be causing problems - SANS Internet Storm Center SANS ISC InfoSec Forums


Sign Up for Free!   Forgot Password?
Log In or Sign Up for Free!
Microsoft Patches appear to be causing problems

Just a heads up to our readers.  We have received multiple reports of Microsoft patches causing machines to hang.   There is also a report that Microsoft has pulled one of the patches.   Specifically, we have had issues reported with the Visual Studio Patch.  We will continue to monitor the situation and keep you posted.   If you have any more information on this please leave us a comment.    

Thank you

Mark Baggett

Mark

81 Posts
ISC Handler
http://forums.overclockers.co.uk/showthread.php?p=27612025
KB3001652 is not a security update but is the one causing freezing of computers while installing. Reports are it's been pulled and when we do a WSUS sync we're not seeing it.
Susan

34 Posts
Also see http://windowsitpro.com/security/first-responders-kb3001652-hangs-computers-never-finishes-installation and http://www.infoworld.com/article/2882348/patch-management/visual-studio-patch-rollup-kb-3001652-causes-widespread-freezing-problems.html

On one system I got a installation window and I had to accept the Eula and continue and finish the installation. On two other system I terminated the 'vstor_redist.exe *32' process! The Windows Update installation continued with the other updates after this.
Susan
5 Posts
None of this is making much sense: none of today's Microsoft bulletins/advisories even mentions Visual Studio, and KB3001652 was released in Sept. 2014. The KB article hasn't been updated, either (which would normally be done if the patch was re-released).

Anyone have any more definitive information?

Garrett Lanzy
Minnesota State Colleges and Universities
Susan
1 Posts
I think what is happening is one of the patches from this month is breaking detection of the VS patch from Oct '14, which triggers it to reinstall but it cannot complete successfully for whatever reason. We've been seeing the same behavior over here as well.
Susan
6 Posts
I provide proactive computer support to people over 55.

All my clients who had Office installed on their computer got hung up in yesterday's Windows update. It took more than 18 hours for one person's update to complete, but his computer may have been restarted and his was the only desktop (other than mine that also failed). All the others were laptops. The only solution was to hold down the physical start button for 5 seconds and restart the computer. That caused several reboots to occur after successive updates were processed. That still left some updates unprocessed.

I found that the Visual Studio update was a primary culprit, though there may have been others. I am in the middle of updating a client's computer now by updating one update at a time. I will report back if any of them get hung up.
GeezerAl

3 Posts
Today there were nine updates processed after the updates failed yesterday. All were installed, though the Windows Malicious Software Removal updates took a while.
GeezerAl

3 Posts
It caused mine to hang, so I stopped it, hard reset the computer, and all was well.
GeezerAl

3 Posts
Looks like they re-released KB3001652? I'm seeing it in WU with a published date of Today (Wednesday 11 Feb).

This is on a system that doesn't have VS 2010 installed, though the writeup still is dated October and still says "To apply this hotfix, you must have Microsoft Visual Studio 2010 installed." The system detecting it doesn't have VS installed, unless having Office 2013 Pro Plus installed is enough to trigger it.
Jaybone

27 Posts
After installing 3209944 I noticed fixed width fonts were not rendering properly, like in this textarea, and my text editor. 3021952 failed to install. System Restore back fixed the rendering of fixed width fonts but now I'm afraid to install the others. I think I'll hold off another day.
Greg

25 Posts
See diary entry 19315 from 2/10/2015, toward the bottom. The font-rendering problem is mentioned with a solution that worked for me on Windows Vista Home Premium.
robv

8 Posts
Today, Friday 13 Feb:
Freshly imaged Win7 SP1 + Office 2013 SP1 system that did not have KB3001652 on the image.
Ran WU, it detected that KB3001652 was needed. I didn't notice if it showed 10th or 11th for the release date.
I let it install, and told it to reboot. The system's now been sitting at "Preparing to configure Windows. Do not turn off your computer" for about half an hour.
Looks like they haven't un-screwed this one just yet. :\
Jaybone

27 Posts

Sign Up for Free or Log In to start participating in the conversation!